注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

眼睛想旅行

技术就是我的生命与信仰!

 
 
 

日志

 
 
关于我

精通C,C++,python,Erlang。并熟悉各种其他编程语言,用cocos2dx游戏引擎作过几个项目。会MySQL增删改查,了解OpenGL渲染原理。懂单片机,能设计数字电路系统,会画电路图和设计电路板。喜欢了解最新前沿技术,并持续关注和学习新技术。

网易考拉推荐

eclipse下安装pydev插件无法显示设置的问题  

2014-02-22 22:15:59|  分类: Python |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
今天在我的android开发环境eclipse上安装python的插件,发现我安装的pydev3.3的版本怎么装都没有出现设置选项,在网上搜了一下,发现有同样问题的人还真不少。原来是因为我的系统自带的java版本过底,我的系统是jdk 1.6的,于是下载了一个pydev2.8的装上之后,问题全解决了。
下边是所有版本的pydev下载地址:
在这里记录一下,方便自已记下来。也方便和我有同样问题的人。
另外,也在这里说一下关于在eclipse下写代码的一些设置
第一个,是关于编写java写代码的时候,文本自动填充的设置,
    打开eclipse下的Preferences->java->Editor->Content Assist,在这里的下边有一个"auto activation triggers for java",一般情况下这里只有一个".",在这里填上"abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ",这样不论输入什么都会自动填充。

第二个问题就是自动填充代码的时候,一般使用的是回车键。但是用习惯了vs,或者xcode的都喜欢用Tab键来自动填充,这个问题网上有一个关于这个方法的插件,大家可以下载下来,然后把eclipse下的原来的插件删除,要不然可能因为新插件版本低动不能很好的工作。下载的地址大家去网上搜吧,我这里就不贴了。

第三个问题就是关于,刚才最上边说的pydev插件中的代码自动填充的。上边的自动填充是关于java的,关于pydev的代码自动填充是在pydev中设置的,具体的设置方法是,Preferences->Pydev->Editor->Code completion中的。"Request completion on '(' ","Request completion on all letter chars and '_' "都选上就OK了,这样这个工具用起来就顺手多了,哈哈。
  评论这张
 
阅读(1544)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017